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Creating Overlays 
 
In this section we’ll learn how to import overlays and place them on Google Earth. These are very handy 
to portray ocean conditions such as SST, SSH, chlorophyll, and other parameters while your drifter is on 
the water. They’re also a great way to show maps of anything to students or other audiences because 
Google Earth provides immediate spatial reference and scale. 
 
Google Earth supports three kinds of overlays. 
 
 
 
Ground or Image Overlays (these are 
synonymous): These are maps or 
images that drape over the 
topography, or over sea level, in 
Google Earth. They could also be 
draped over the sea floor bathymetry. 
 
Screen Overlays: These images are 
pinned to a certain part of the Google 
Earth 2D screen, like the upper left, 
lower right, or dead-on center. They 
are good for logos or legends that 
explain maps displayed as image 
overlays. 
 
 
 
 
 
 
 
 
 
 
Photo Overlays: These are 
photographs that are geo-referenced 
and placed at the exact location and 
orientation that the photograph was 
taken. Viewers can then “fly into” the 
photographs. Gigapans are an example 
of Photo overlays. Unless time permits 
or interest demands, we will not dwell 
on photo overlays in this workshop. 
 

Image Overlay: Sea Surface 
Temperatures over sea level 

Screen Overlay: a legend 
pinned at lower right  
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Adding an Image Overlay 
 
The first step is to find a nice map or 
image to add to Google Earth. Here’s one 
that’s nice and simple and a good example 
to learn from (right). Note that it contains 
more information than just a map. Also, 
for later in the exercise, note that the 
green, red, and grey pie chart is perfectly 
circular.  
 
Here’s the URL: 
http://sanctuarysimon.org/monterey/ima
ges/build/b_overview_map_full.jpg 
Download the jpg to a folder that you will 
remember.  Note that those spaces are 
“_” characters in the file name. (In the 
browser, right click and choose “Save 
Picture As…”) 
 
The associated web site has lots of good 
information about the MBNMS: 
http://sanctuarysimon.org/monterey/sect
ions/beaches/maps_graphs.php  
 
 
 
 
 
Open Google Earth and press Add > Image Overlay.  A window will open. 
 
In the “New Image Overlay” window that opens, press the browse button and search for the jpg that 
you just saved (this is a test). Open the image and leave the New Image Dialog box open (don’t click OK 
just yet.) 
 

**Note: you could enter the URL for this image so that Google Earth would download this image 
from the Internet rather than your hard drive. There are advantages and disadvantages to this 
approach.  

 The advantage is that your resulting KML file will be much smaller and easier to save, send, 
open, and otherwise manipulate.  

 The disadvantage is that the owners of this website could take the image down at any time, or 
the external server could become very slow at inopportune times. 

 
Once you’ve have either an address from your hard drive or a URL from the Internet in the “Link:” box, 
and you put the curser anywhere else, you should see the image in the 3D viewer of Google Earth. The 
image should have green lines on the sides and at the corners.  
 

http://sanctuarysimon.org/monterey/images/build/b_overview_map_full.jpg
http://sanctuarysimon.org/monterey/images/build/b_overview_map_full.jpg
http://sanctuarysimon.org/monterey/sections/beaches/maps_graphs.php
http://sanctuarysimon.org/monterey/sections/beaches/maps_graphs.php
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You can give the image a name in the “Name:” box. This will identify the image in the Places panel  (like 
a table of contents.) 

In this screen shot, the jpg image has just been added and given a name, “Beach Types”.  Note that I’ve 
used the URL in this example. You can also write in a description of this map.  
 
To help position this particular jpg, you may want to turn on the coordinate grid in Google Earth to see 
the latitude and longitude lines (View > Grid). [You will need to click OK in the New ImageOverlay 
window to access the View menu.] 
 
It is an iterative process. You can press OK to get out of the “New Image Overlay” window. To return to 
the positioning process, right click the overlay in the Google Earth list view and press “Properties”. When 
finished, remember to leave the Transparency slider all the way on “Opaque”.  
 
To change the transparency of the 
overlay when viewing normally in Google 
Earth, highlight the overlay in the list 
view and then move the slider at the 
bottom of the Places panel. 
 
On the right is the jpg in the final stages 
of positioning, while still in a semi-
transparent state. Don’t forget to 
increase the opacity before pressing 
“OK” for the final time. 
 
Now let’s take a look at the KML that 
describes our overlay. Use the copy-and-
paste trick to copy the KML into 

To position the image overlay… 
 
1. Click and drag the Transparency slider 

to make the jpg partially transparent. 
 

2. Click and drag the green handles 
surrounding the jpg image in the 3D 
area to position it. 
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Notepad++.  [Right click on the name in the Places panel and select copy, open up Notepad++ and select 
paste.]  The image below is a screenshot that shows the Notepad++ window on top of the Google Earth 
window.  Admire the simplicity and efficiency of the script. 
 
 
Save this KML file to your hard disk, calling it “ImageOverlaySimple.kml”.  We’ll use this file later. 
 

A note on Projections. Note that the pie diagram on the overlay is deformed. This is because the 
projection of the original map was different than the projection used by Google Earth.  Google Earth 
changed the projection of the overlay during the fitting process.  I believe that Google Earth can deal 
with any projection where the lines of latitude and longitude are perpendicular, as in the geographic 
projections.  
 
Now let’s go back to our image overlay in Google Earth and add some complexity. 
 
First change the view in the 3D viewer by zooming in or out, rotating the view, tilting the view, or 
whatever. 
 
Right click on the overlay in the Places panel and select “Properties”. 
 
Write a description in the box that is longer than two lines. 
 
Press the View tab, and then press the “Snapshot Current View” button.   
 
Press “OK”. 
 

Each of the <north>, <south>, <east>, 
and <west> elements within the 
<LatLonBox> element describe one of the 
boundaries of the overlay. The <west> 
element is highlighted here. Note that 
these elements correspond to the 
boundaries of the overlay, not the 
boundary of the map within this 
particular overlay. 
 

The <Icon> element 
behaves just as it did 
within the <Style> 
element in a previous 
example. 
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Note what has happened in the Places panel. The first couple of lines of your description should now be 
visible.  
 
Single left-click on the overlay in the list view and a balloon should appear with your entire description.  
 
Double left-click on the overlay in the list view and the 3D view should move to the position that you 
entered when you pressed “Snapshot Current View”.  
 
Now use the copy-and-paste trick to view the KML for the newly enhanced overlay in Notepad++. 
 
What’s new? 

 
 
 
Save this KML file to your hard disk, calling it “ImageOverlayComplex.kml”. 

The <description> 

element holds the 

description you entered. 

The <LookAt> element 

holds the view information 

in a manner similar to the 

previous example. 

Everything else is the same! 

Admire the simplicity. 
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Screen Overlays 
 
Screen overlays cannot be authored from within Google Earth; we must use a text editor to create their 
KML code. They are used to “glue” an image to a fixed part of the 3D screen, like upper left, lower right, 
etc… Screen overlays are used to display logos, legends, or other images that you don’t want to 
disappear out of view as you move around the map in Google Earth. 
 
Page 130 in “The KML Handbook” has a good graphic illustrating some of the important terms for screen 
overlays. 
 

 Go to the KML Tutorial at http://code.google.com/apis/kml/documentation/kml_tut.html  

 Scroll down to the table of contents, find Screen Overlays, and click on it. 

 Highlight the green example code and copy it. 

 Go to Notepad++ and paste it in. 
o Note: the code may paste in all as one line, making it difficult to read. 
o If this happens, keep following these directions anyway; the issue should rectify itself in a few 

steps. 

 Save the file as a .kml file called ScreenOverlay.kml in a folder that you will remember.  We will 
return to this file in a later tutorial. 

 Go to Google Earth and open your ScreenOverlay.kml file. You should see a very simple little graphic 
in the upper left corner. 
o If the code pasted badly in only one line last time, use the copy-and-paste trick to copy the 

ScreenOverlay.kml file and paste it back into Notepad++. This time, you should see the KML in a 
more digestible format.  

 

Here’s the screen overlay we just 
added. The red dot represents 
the point on the overlay image 
defined by <overlayXY> and the 
point on the screen defined by 
<screenXY>. The image is 
positioned by aligning these two 
points. The KML is shown on the 
next page.  

http://code.google.com/apis/kml/documentation/kml_tut.html
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Now let’s look at the KML to see what it’s doing. 
 
Basically, a screen overlay is a jpg or other graphic file located either on your hard drive or on an 
Internet server. The KML references this image, assigns a reference point to the image and matches it to 
a reference point on the 3D view area (see the image on page 130 of “The KML Handbook”).  

 The <overlayXY> element assigns a reference point to the graphic image file.  The point is measured 
in pixels or fractions of the entire image as measured from the bottom left corner.   

 The <screenXY> element assigns a reference point on the screen, again measured in either pixels or 
fraction of the entire screen as measured from the bottom left corner.  

You can think of a nail attaching the image to the screen; the nail goes through both <overlayXY> and 
<screenXY>. 

 The <size> element controls the size of the image used in the screen overlay. There are various 
options to use for both the x and y dimensions (see the Handbook, p 131), but I think using either -1, 
which specifies to use the image as is, or n, representing any number, is the safest.  As with all the 
other child elements, the units can be in either pixels or fractions of the original image size. 

 
 

 
 
 

In this case, the <overlayXY> element sets the reference point 
at the upper left corner of the image file. Note that the units 
are fractions. So a fraction of “1” means the entire distance 
across the image.  Remember that the origin is at the lower 
left corner. So y=”1” means all the way across the image in the 
y direction (up). This reference point on the image will be 
aligned with the point defined by <screenXY> on the screen. 

In this case, the <screenXY> element sets the reference point at 
the upper left corner of the screen. Note that the units are 
fractions. So a fraction of “1” means the entire distance across 
the screen. Remember that the origin is at the lower left corner. 
This reference point on the screen will be aligned with the point 
defined by <overlayXY> on the image. 
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Using What You’ve Learned 
 
The point of this section is to alter and play with the KML files you’ve created to gain familiarity with 
controlling how KML scripts control the overlays. 
 
Some beginning ideas: 
 
Open one of the KML files that we’ve worked with in your text editor.  Alter one or two of the values in 
the various elements. Save the KML file.  Open the KML file in Google Earth (or use Revert).  Repeat until 
you’re comfortable with the concepts/elements we’ve covered and maybe even a few more. 
 
Some intermediate ideas: 
 
Go to the KML tutorial http://code.google.com/apis/kml/documentation/kml_tut.html 
Scroll down to the screen overlay section and download the KML Samples file, downloading it to a place 
you’ll remember.  
Open this KML file in Google Earth.  
Open the Screen Overlays and Ground Overlays sections and look at the various examples. 
Use the copy-and-paste trick to copy the KML to Notepad++ and look at the KML code. 
Analyze the KML to see if you can tell why the overlays are behaving differently. 
 
Find your favorite map on the Internet or from your collection, that is saved as a jpg or png file. 
Place your map into Google Earth using Add > Image Overlay and the techniques we covered in this 
section. 
 
Some advanced ideas: 
 
Read the “KML Handbook” or the on-line KML tutorial referenced above to figure out how to rotate a 
screen overlay. 
Determine the difference between <rotationXY> and <rotation>. 
Place a successfully rotated Screen Overlay on Google Earth and show it off to the rest of us. 
 
Read the “KML Handbook” or the on-line tutorial referenced above to figure out how to insert a photo 
overlay into Google Earth.  
 
Access one of your photographs, or one from the Internet, and insert it into Google Earth and show it off 
to the rest of us. 
 
It helps if you know exactly where the photograph was taken. 
 
A nice YouTube video explanation of how to do this is here: 
http://www.gearthblog.com/blog/archives/2008/04/advanced_photo_placement_in_google.html  
 
 
 
Have fun! 
 

http://code.google.com/apis/kml/documentation/kml_tut.html
http://code.google.com/apis/kml/documentation/KML_Samples.kml
http://www.gearthblog.com/blog/archives/2008/04/advanced_photo_placement_in_google.html

