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Introduction to KML 

In this section, we’ll learn the very basics of how KML is structured and 

written. 

References: 
Google has a beginning KML tutorial: 
http://code.google.com/apis/kml/documentation/kml_tut.html 
Some of the examples in this section come from this tutorial. 
 
The most complete on-line reference for KML is Google’s KML reference page (can be a bit terse): 
http://code.google.com/apis/kml/documentation/kmlreference.html 

The best reference for easy-to-read explanations of KML is Josie Wernecke’s book, “The KML 
Handbook”. 
http://www.amazon.com/KML-Handbook-Geographic-Visualization-Web/dp/0321525590 
This book comes with an on-line repository for all the KML script described in the book. The URL for this 
repository is http://www.informit.com/title/0321525590 Pressing the “Download the code” button 
brings a zipped folder to your computer. 
 
 

 

 

 

 

 

 

 

 

 

 

 
Text Editors for Writing Code: 
When working with computer codes or scripts, it is highly desirable to use a text editor designed 
specifically for code editing. We recommend Notepad++, a freely downloadable code editor. 
http://notepad-plus-plus.org/ 

Click here for KML 

Handbook code. 

2009 drifter deployment from 

Cape Fear Community College 

http://code.google.com/apis/kml/documentation/kml_tut.html
http://code.google.com/apis/kml/documentation/kmlreference.html
http://www.amazon.com/KML-Handbook-Geographic-Visualization-Web/dp/0321525590
http://www.informit.com/title/0321525590
http://notepad-plus-plus.org/
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First KML Examples 
Go to Google’s on-line KML tutorial: http://code.google.com/apis/kml/documentation/kml_tut.html 
Scroll down to the first code example, in green font, labeled “Placemarks”. Use control-c to copy this 
code (the green type) and paste it into a code text editor like Notepad++. Do not use Word or a word 
processor designed to make text documents. 
 
Save this document as 
“FirstPlacemark.kml” to a folder 
that you will remember. It is 
very important that you ensure 
that the extension is “.kml” and 
not anything else, like “.txt”. 
 
Your document should now look 
something like the image to the 
right (except that you’re using 
Notepad++ and not Notepad). 
 

 
Open Google Earth and press File > Open. 
Navigate to the folder where you saved 
your FirstPlacemark.kml file and open the 
file. The Google Earth Screen should look 
something like the image to the left. That’s 
the Google Headquarters in Mountain 
View, CA. 
 
 
 
 
 

Some Definitions 
 

Element: the words within the angled brackets < >. The beginning of the element is indicated by the 
name in angled brackets, like <name>; the element ends with an angled bracket and a slash preceding 
the name, like </name>.  Elements are case sensitive, so be extra careful.  
 

Value: the letters, numbers or more elements contained between these beginning and end of the 
elements. 
 

Complex Elements: Those that contain other elements, like <name> or <coordinates>. Complex elements 
are always capitalized, like <Placemark> and <Point>. This system of complex elements containing other 
elements gives KML its structure. Each complex element can contain only a well-defined selection of 
other elements.  
 

Simple Elements: can only contain data such as letters, numbers and symbols, such as <coordinates>-
122.0822035425683, 37.42228990140251, 0</coordinates> which is the location of the placemark 
representing the Google Headquarters. Simple elements are lower case. 

http://code.google.com/apis/kml/documentation/kml_tut.html
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How KML Relates to What You See in Google Earth 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

All KML files begin 
with these lines. 
Just include them. 

The <description> of 
the <Placemark> 
appears in the List View 
(first two lines) and in a 
balloon when the icon 
is clicked. 

The <name> of 
the <Placemark> 
appears in both 
the 3-D viewer 
and the List View 

<Placemark> contains 
information about 
geometrical elements 
such as points, lines, 
or polygons.  

<Point> contains the 
coordinates of the 
placemark. 

Don’t forget to close 
any element that was 
begun. 
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Altering KML from within Google Earth -- The Copy-and-Paste Trick 
 
Let’s try and change a few things in our KML file. We can do this either at our text editor, or through 
Google Earth. We’ll go through Google Earth first, employing the “copy-and-paste trick” 
 
With the Simple Placemark KML file still visible, alter the view in the 3D viewer by tilting the view to 
about 45⁰ and turning the view to the west so that you can see both the Google Headquarters and 
Shoreline Amphitheater (where I barely remember attending Grateful Dead concerts), as shown below. 
It doesn’t really matter how the view changes for this example, as long as it is changed. 
 
Right click on the Simple Placemark in the List View and choose “Properties”. In the “Edit Placemark” 
window that opens, choose the “View” tab and then press the “Snapshot current view” button as shown 
below. Click Ok. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Now move to another location in Google Earth.  
 
Double click on the Simple Placemark in the List View and see what happens. It should bring you back to 
your “snapshot” of the Shoreline Amphitheater. 
 
Save this file by right clicking it and choosing “Save Place As…” Navigate to the same folder as your 
previous KML file and save this one as “FirstPlacemarkView.kml”. 
 
How does this look in KML? Here comes the copy-and-paste trick. 
 
Right click the Simple Placemark in the List View again. This time, choose “Copy”. 
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Go to your text editor. Open a blank document. Press control-v (or Edit>Paste). Ta-da! The new KML 
should appear before your eyes.  
 
Here is the new KML file—FirstPlacemarkView.kml—from Google Earth. Let’s see what’s new. 
 
 
  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Altering KML from the Text Editor and Using “Revert” 
 
Now we’ll go the other way around: altering the KML from within the text editor, saving it, and then 
looking in Google Earth to see the changes. 
 
Let’s change some things in the “FirstPlacemarkView.kml” file. Try changing the value in the <heading> 
element. Try something radically different than the current <heading> value, like 180.  
 
Save the KML file using the same folder and same name – “FirstPlacemarkView.kml”. 
 
Now go back to Google Earth, right-click the KML file and choose “Revert”. Answer affirmatively to the 
usual question about whether you really want to do it. You should see the heading of the 3D View area 
change to 180⁰.  
 

The <Style> element is a complex element that 
can have quite a few “children” elements within 
it to describe the appearance of placemarks. 
Note that it occurs outside of the placemark. This 
one is fairly simple because the yellow pushpin is 
somewhat of a default for Google Earth. The 
<Style> on your computer may be a little more 
complicated. See the last page of this handout. 

The <styleUrl> element 
references the <Style> 
element described 
above. Note that this 
one is within the 
<Placemark>. 

The <LookAt> element is 
the main new addition. 
Its “child” elements 
describe the new view 
that we took the 
snapshot of earlier. 
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The <altitudeMode> and <gx:altitudeMode> elements aren’t really needed, since the values they 
contain are the defaults. Try erasing them, saving the file, and going to Google Earth to use the “Revert” 
command. See if anything changes. 
 
Practice this process several times until you are comfortable using both techniques: changing the KML 
and seeing the results in Google Earth, and making changes in Google Earth and seeing the results in the 
KML in a text editor. If things get screwed up, just load the FirstPlacemark.kml” file into Google Earth 
again and start over.  
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A Note About <Style> 
 
When using the copy-and-paste trick, Google Earth likes to use the <Style> element. It’s not that 
important to our goal in this workshop, but you’ll probably see it, so it’s a good idea to understand 
what’s going on. Styles are used to define—all at the same time—the way that many icons should look. 
 
Go to Google Earth and erase any KML files. Highlight Temporary Places in the List View and add a 
placemark by pressing Add>Placemark. Put it anywhere. It doesn’t matter where. Press “OK” in the 
“New Placemark” window that opens. Note that the icon changes a bit when it is moused over. 
 
Right click the Untitled Placemark and choose copy. Go to your text editor and paste. The KML file 
should look something like this (first few lines deleted to save space; bolded boxes refer to styles): 
 
 
 
 
 
 
 
 

<Document> 
 <name>KmlFile</name> 
 <StyleMap id="msn_ylw-pushpin"> 
  <Pair> 
   <key>normal</key> 
   <styleUrl>#sn_ylw-pushpin</styleUrl> 
  </Pair> 
  <Pair> 
   <key>highlight</key> 
   <styleUrl>#sh_ylw-pushpin</styleUrl> 
  </Pair> 
 </StyleMap> 
 <Style id="sn_ylw-pushpin"> 
  <IconStyle> 
   <scale>1.1</scale> 
   <Icon> 
    <href>http://maps.google.com/mapfiles/kml/pushpin/ylw-pushpin.png</href> 
   </Icon> 
   <hotSpot x="20" y="2" xunits="pixels" yunits="pixels"/> 
  </IconStyle> 
 </Style> 
 <Style id="sh_ylw-pushpin"> 
  <IconStyle> 
   <scale>1.3</scale> 
   <Icon> 
    <href>http://maps.google.com/mapfiles/kml/pushpin/ylw-pushpin.png</href> 
   </Icon> 
   <hotSpot x="20" y="2" xunits="pixels" yunits="pixels"/> 
  </IconStyle> 
 </Style> 
 <Placemark> 
  <name>Untitled Placemark</name> 
  <LookAt> 
   <longitude>-95.2654839812744</longitude> 
   <latitude>38.95938974029625</latitude> 
   <altitude>0</altitude> 
   <heading>-4.949370908718821e-007</heading> 
   <tilt>0</tilt> 
   <range>11004250.69468234</range> 
   <altitudeMode>relativeToGround</altitudeMode> 
   <gx:altitudeMode>relativeToSeaFloor</gx:altitudeMode> 
  </LookAt> 
  <styleUrl>#msn_ylw-pushpin</styleUrl> 
  <Point> 
   <altitudeMode>clampToGround</altitudeMode> 
   <gx:altitudeMode>clampToSeaFloor</gx:altitudeMode> 
   <coordinates>-95.2654839812744,38.95938974029625,0</coordinates> 
  </Point> 
 </Placemark> 
</Document> 
</kml> 

Note the <name> within <Document> 

<StyleMap> defines two different 
styles, one for the normal icon, and 
the other for when the icon is 
moused over, or highlighted. Note 
the <key> is either “normal” or 
“highlight”. The <styleUrl> gives the 
reference within the kml script for 
the two different styles. 

Here are the two <Style> elements, one called “sn_ylw-
pushpin” for normal, and the other called “sh_ylw-
pushpin” for highlight. Each <Style> comes with its 
individual <IconStyle>, which comes with a scale—the 
highlighted one is bigger—and a url <href> for the 
location of the icon on one of Google’s servers. 

Note the <name> within <Placemark>. In Google Earth, can you 
see how this one differs from the one within <Document>? Try 
changing this <name> to something more appropriate. 

Here is the <styleUrl> element within the <Placemark>, 
referencing the <StyleMap> near the top of the script. 

<altitudeMode> and <gx:altitudeMode> are probably unneeded because they 
contain default values. Try looking up other values for <altitudeMode> in the 
references, changing it, and seeing the effect in Google Earth. 
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Using What You’ve Learned 
 

The point of this section is to alter and play with the KML files you’ve created to gain familiarity with 
customizing Google Earth KML files by writing and editing KML files and making the KML do what you 
want it to. 
 

Open one of the KML files that we’ve worked with in your text editor. Alter one or two of the values in 
the various elements. Save the KML file. Open the KML file in Google Earth (or use Revert). Repeat until 
you’re comfortable with the concepts/elements we’ve covered and maybe even a few more. 
 

Some beginning ideas: 

 Change the location of the icon by changing the numbers in the <coordinate> element. 

 Change values in the <LookAt> element.  
o Start with <longitude>, <longitude>, <heading>, and <tilt>. 
o What does the <altitude> element do? 
o What is the difference between <altitude> and <range>?  

- (Nice diagram on p. 34 of “The KML Handbook”.) 
o What does <altitudeMode> do? What are the other values that can be entered here?  

- (Nice <altitudeMode> diagram on page 49 of “The KML Handbook”.) 
 

Some intermediate ideas: 

 Change the icon’s size (<scale>) 

 See if you can change the behavior of the icon when it is highlighted by a mouse-over.  

 Try making the KML invoke no changes at all when the icon is moused over. 

 Change the icon by referencing a different PNG file on the Google server. Try putting a totally 
different icon into the highlight style—say a coffee cup, arrow, dollar sign, or balloon instead of a 
pushpin.   

 

How to find the URL of icons (in PNG format) 
on the Google server:  
In Google Earth, right click on any placemark 
and choose “Properties”.  
At the very top right of the “Edit Placemark” 
window is a button with a picture of the icon 
presently in use. Click this button. 
In the “Icon” window that opens, you’ll see a 
selection of icons. Single left-click on any of 
them. Its URL will appear in a little box near the 
top of the window. Highlight the URL, copy it, 
and paste it into an appropriate <href> 
element in your KML file.  
 

Some advanced ideas: 
Insert additional elements into the <IconStyle> element. These are listed and explained in pages 79-85 
of “The KML Handbook”. If you play with color, choose a white icon from the selection shown above. A 
nice table of hexadecimal values for the <color> element is shown on page 26 of the Handbook. 


